add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

RGB LED Strip Troubles

ahmedarbab234

12 months ago

Hi there,

Completely new to PC building/gaming. Bought the Immax Neo RGB + CCT LED pasek 1m and having trouble installing it into my rig.

Working with the Gigabyte B450M-DS3H motherboard and the EVGA 600W Power Supply.

The motherboard has a dedicated 4 pin male header specifically for RGB LEDs. But trouble is my strips only have a 6 pin connector. And I can't find anywhere whether there is an adapter for the issue. Do I have to plug it into the power supply somehow? I'm quite lost as I had the PC assembled for me so I'm clueless about the actual component mechanics.

Thanks for the help in advance!

A

Comments

[comment deleted]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube