PCPartPicker

  • Log In
  • Register

Blue Yeti Nano troubles with SHERPA soft

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

Egyptolog 3 months ago

Hi there! Just received my new Blue Yeti Nano, and plug-in with my PC, all works fine, and I downloaded a SHERPA, SHERPA said that I need to update my mic, after updating SHERPA saying that it appears that I don't have any devices connected... I tried to delete my mic from Device Manager, I tried to reinstall SHERPA, I tried to restart my PC, I tried to download SHERPA to my laptop and connect my mic, and it didt work. Mic is working good, but SHERPA doesn't see it.

Maybe you may help me cuz the support works from Monday to Tuesday :( I think it could happen with many people so if you know how to fix it you will be a hero :)

UPD: Best way https://www.youtube.com/watch?v=BeGIw9DDZ5s

Comments Sorted by:

slkipp 1 Build 1 point 3 months ago

What is Sherpa?

Egyptolog submitter 1 point 3 months ago

Soft for Yeti Nano

Egyptolog submitter 1 point 3 months ago

So guys, you really don't need this fkn SHERPA. This way really works https://www.youtube.com/watch?v=BeGIw9DDZ5s