add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

M.2 drive not showing up in Bios

OccamAsylum

46 months ago

I got a Samsung 850 Evo m.2 2280 installed on the back of my MSI B150I Pro Gaming AC. It doesn't show up in the bios and when I attempted to install Windows on it, there was no drive to choose from.

I forget what I did at the moment, but I looked at the contents when attempting to install Windows and there was an X: drive? I don't know what that is. It wasn't my external optical drive because that showed up clearly.

I just tried reseating it and had no luck. Help would be much appreciated. I have to leave for work so I can't do anything else for the time being.

Comments

  • 46 months ago
  • 1 point

Damn that's a bummer, but easy enough to solve. I should have checked ahead of time instead of assuming it would work.

[comment deleted]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube