add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

No sound from G930

ThreeScoops

47 months ago

So I recently built a PC, and bought these G930 headphones. Unfortunately, I can't get any sound to come from them. It is my default audio player, my computer recognizes it, and I have downloaded the drivers for it, so I'm not sure what's wrong. If anyone could help, I'd appreciate it.

Comments

  • 47 months ago
  • 1 point

Do you have the logitech gaming software? or are you talking about windows drivers for it?

  • 47 months ago
  • 1 point

Well I'm not too sure about the nomenclature of drivers, but I did install the logitech gaming software, not sure what a windows driver is.

  • 47 months ago
  • 1 point

I updated windows, that fixed it, thanks.

  • 47 months ago
  • 1 point

You've checked the volume scroller on the cable? (Assuming it has one) Sometimes really simple things are the answer. Ive done it before.

  • 47 months ago
  • 1 point

Here's a good post in case they turn off every 15 minutes while you are using them.

https://forums.logitech.com/t5/Logitech-G-Headsets/Logitech-G930-turns-off-every-20-minutes/m-p/1422736#M4940

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube