add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Help! First time building pc, monitor no signal when power on

menghui
  • 58 months ago

Hello everyone! I'm building a pc for the first time. After turning on the power, there is no signal on monitor, no beep. I checked some parts. CPU fan is running. CPU liquid cooling is lightening. Video card fan runs at the beginning of power on. I checked the PSU, here is my connection: 24 pin motherboard power. 8 pin CPU power. 6+2 pin video card power. power+data connector for my SSD and HDD. The monitor works well with another computer. I also tried to clear the CMOS once, still no luck. What can I do now? Any help or advice will be appreciated! Thank you so much!

Here is my build list: http://pcpartpicker.com/p/4syrgs

Comments

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube