add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

APU not displaying video

Twee
  • 58 months ago

okay so i installed everything correctly and when I turn it on and plug any display output nothing shows up anyone knows why?

parts: Asus A68HM-K motherboard

amd A10- 7870k apu

CORSAIR Vengeance Pro 8GB 2 DDR3 2400

adata 128gb ssd

rosewill 700w power supply ( been using for awhile just used to test)

using stock cpu cooler as of now but when i try to plug in any display outputs nothing shows up. the cpu fan is spinning and I tried to use a 260x and still not showing any display.

motherboard issue?

Comments

  • 58 months ago
  • 1 point

There are a number of possibilities:

  • Loose connection to the motherboard

  • RAM isn't securely fastened

  • The video cord (HDMI, etc) could be bad

  • Monitor could be bad

My first step would be to verify that your video cord works by plugging it into something you KNOW works.
Second step would be to verify the monitor by the same method above.
Third step would be to take the RAM out and only try one stick at a time.
Fourth step would be to check EVERY connection. Literally unplug everything and plug it all back in.

  • 58 months ago
  • 1 point

sounds like a bios update issue, considering this is the latest APU with an older motherboard which we don't know if its the first revision or a later one...

  • 58 months ago
  • 1 point

I was originally thinking this, but PCPP's tool didn't flag it. You're right though, this is probably the issue.

  • 58 months ago
  • 1 point

strange.... maybe the flag was only with the 860k..

  • 58 months ago
  • 1 point

Shouldn't be, though. The 7870K is newer...

  • 58 months ago
  • 1 point

exactly!! that's the thing, there is no flag wwith any motherboard when you select the 7870k..

  • 58 months ago
  • 1 point

still nothing, I think I need to update bios

  • 58 months ago
  • 1 point

Try to plug it in to a TV, see if that works. Then, you'll know it is a monitor issue.

  • 58 months ago
  • 1 point

I'm pretty sure your problem is that the motherboard needs a bios update for the A10-7870k to work.. remember the A10-7870k is the latest APU and the motherboard was release November 2014. You need to install latest bios 0805 for it to work.

https://www.asus.com/Motherboards/A68HMK/HelpDesk_CPU/

https://www.asus.com/Motherboards/A68HMK/HelpDesk_Download/

Don't know where you bought it, but maybe you can get a cheap APU to do the update

http://pcpartpicker.com/part/amd-cpu-ad6300okhlbox

or contact ASUS or exchange your motherboard...

  • 58 months ago
  • 1 point

i got it from a newegg bundle was like 365$ for everything i got his for my brother so i need another cpu to do the bios update probably. Hopefully After doing the bios it will work.

  • 58 months ago
  • 1 point

why don't you call ASUS, ask them which bios it has, they should know by the revision of the motherboard.. that way you verify 100% that the problem is the bios update.. I think it is... but there is the slight 0.01% that it isn't .. :)

  • 58 months ago
  • 1 point

they didn't tell me :( I ordered the cheap apu to see if the motherboard actually works cause wasn't able to get any display output. so hopefully i can update the bios and get the 7870k working

  • 58 months ago
  • 1 point

good luck... tell us how it turned out.

  • 58 months ago
  • 1 point

Will do I read some reviews about other similar motherboards and all had to buy a lower price apu to download the BIOS for the 7850k and 7870k so hopefully that's my issue. Then I guess I can keep the lower price apu and build a computer for my mom

[comment deleted]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube